按月存档: 2010/11

让ie6支持png透明的js

分类:网站技术日期:2010-11-27 - 17:20:49评论:14条作者:老谢

<script language="JavaScript"> 
function correctPNG() // correctly handle PNG transparency in Win IE 5.5 & 6. 
{ 
    var arVersion = navigator.appVersion.split("MSIE") 
    var version = parseFloat(arVersion[1]) 
    if ((version >= 5.5) && (document.body.filters)) 
    { 
       for(var j=0; j<document.images.length; j++) 
       { 
          var img = document.images[j] 
          var imgName = img.src.toUpperCase() 
          if (imgName.substring(imgName.length-3, imgName.length) == "PNG") 
          { 
             var imgID = (img.id) ? "id='" + img.id + "' " : "" 
             var imgClass = (img.className) ? "class='" + img.className + "' " : "" 
             var imgTitle = (img.title) ? "title='" + img.title + "' " : "title='" + img.alt + "' " 
             var imgStyle = "display:inline-block;" + img.style.cssText 
             if (img.align == "left") imgStyle = "float:left;" + imgStyle 
             if (img.align == "right") imgStyle = "float:right;" + imgStyle 
             if (img.parentElement.href) imgStyle = "cursor:hand;" + imgStyle 
             var strNewHTML = "<span " + imgID + imgClass + imgTitle 
             + " style=\"" + "width:" + img.width + "px; height:" + img.height + "px;" + imgStyle + ";" 
             + "filter:progid:DXImageTransform.Microsoft.AlphaImageLoader" 
             + "(src=\'" + img.src + "\', sizingMethod='scale');\"></span>" 
             img.outerHTML = strNewHTML 
             j = j-1 
          } 
       } 
    }     
} 
window.attachEvent("onload", correctPNG); 
</script>
Tags:

单臂路由的配置

分类:网络技术日期:2010-11-25 - 22:37:08评论:4条作者:老谢

单臂路由的配置

Switch>enable
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 2
Switch(config-vlan)#exit
Switch(config)#vlan 3
Switch(config-vlan)#exit
Switch(config)#int fa 0/2
Switch(config-if)#switchport access vlan 2
Switch(config-if)#int fa 0/3
Switch(config-if)#switchport access vlan 3
Switch(config-if)#int fa 0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#end

路由器

Router>enable
Router#conf terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int fa 0/0
Router(config-if)#no shutdown
 
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config-if)#int fa 0/0.1
 
%LINK-5-CHANGED: Interface FastEthernet0/0.1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.1, changed state to 
Router(config-subif)#encapsulation dot1Q 2
Router(config-subif)#ip add 192.168.1.1 255.255.255.0
Router(config-subif)#exit
Router(config)#int fa 0/0.2
 
%LINK-5-CHANGED: Interface FastEthernet0/0.2, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.2, changed state to 
Router(config-subif)#encapsulation dot1Q 3
Router(config-subif)#ip add 192.168.2.1 255.255.255.0
Router(config-subif)#end

配置telnet登陆及特权模式密码

分类:网络技术日期:2010-11-24 - 21:57:56评论:0条作者:老谢

拓扑图

实验目的:配置pc telnet登陆交换机及特权模式的密码

配置过程如下

Switch>en
Switch#conf terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#int vlan 1
Switch(config-if)#ip add 192.168.1.1 255.255.255.0
Switch(config-if)#no shutdown
 
%LINK-5-CHANGED: Interface Vlan1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
Switch(config-if)#exit
 
Switch(config)#enable password 123456
Switch(config)#line vty 0 4
Switch(config-line)#password xj123
Switch(config-line)#login
Switch(config-line)#end

pc用telnet登陆

首页与内页不同title

分类:折腾日期:2010-11-23 - 12:30:16评论:5条作者:老谢

本人需要首页和内页的文章标题不一样

本来是把heade的东西复制到index

不过这样增加了index的代码量而且不方便

完美解决方法如下,ps:感谢小鬼

<title>
<?php if (is_home() ) {  ?><?php bloginfo('name'); ?> _ <?php bloginfo('description'); ?>
<?php }  else {?><?php wp_title(''); ?> _ <?php bloginfo('name'); ?> <?php  } ?>
</title>

馊博客改版计划

分类:网站运营日期:2010-11-21 - 21:52:24评论:3条作者:老谢

馊博客已经低调很久了

论坛关闭也已经一个多月了

可是馊博客不能倒,论坛大家都没有时间管理,所以现在决定做一个导航

独立博客的导航站点,到时候“馊博客”可能改名为“搜博客”

在这里,你可以搜索到你感兴趣的博客

就说这么多

现在程序选定114啦的导航程序

已经在本地调试,计划12月中旬可以试运行

年底正式上线

希望大家到时候可以捧个场~

简单设置关闭恶心的QQ邮箱漂流瓶

分类:乱七八糟日期:2010-11-20 - 18:59:13评论:2条作者:老谢

本人一直使用QQ邮箱

但最近腾讯开通的漂流瓶服务实在是恶心,有事没事飘来几个瓶子

个人感觉跟垃圾邮件没什么区别

无聊的人才会扔那玩意

然后在进入漂流瓶的操作界面,发现并没有关闭或者注销之类的功能

便以为是腾讯强制推广的一款产品

今天去设置,无意间看到可以关掉,所以发本文希望对跟一样需要关闭的朋友有帮助

具体操作是,进入邮箱后,点击“设置”,如图

简单设置关闭恶心的QQ邮箱漂流瓶

利用三层交换机vlan间通信

分类:网络技术日期:2010-11-20 - 16:02:24评论:1条作者:老谢

利用三层交换机vlan间通信

首先在交换机上配置vlan

配置过程如下

Switch>en
Switch#conf termi
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 2
Switch(config-vlan)#exit
Switch(config)#vlan 3
Switch(config-vlan)#exit
Switch(config)#int fa 0/2
Switch(config-if)#sw access vlan 2
Switch(config-if)#int fa 0/3
Switch(config-if)#sw access vlan 2
Switch(config-if)#int fa 0/4
Switch(config-if)#sw access vlan 3
Switch(config-if)#int fa 0/5
Switch(config-if)#sw access vlan 3
Switch(config-if)#int fa 0/1
Switch(config-if)#sw mode trunk

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
Switch(config-if)#no shutdown

我们现在分别ping一下看看

利用三层交换机vlan间通信

vlan2内的192.168.1.3可以ping通

vlan3的192.168.2.2掉包

我们开始配置路由器

Switch>enable
Switch#conf terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 2
Switch(config-vlan)#exit
Switch(config)#vlan 3
Switch(config-vlan)#exit
Switch(config)#int fa 0/1
Switch(config-if)#sw mode trunk
Switch(config-if)#no shutdown
Switch(config-if)#int vlan 2

%LINK-5-CHANGED: Interface Vlan2, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2, changed state to upSwitch(config-if)#ip address 192.168.1.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#int vlan3

%LINK-5-CHANGED: Interface Vlan3, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan3, changed state to upSwitch(config-if)#ip add 192.168.2.1 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#end

配置完毕,我们可以show下路由表

下面我们ping试试看

利用三层交换机vlan间通信

vlan2和vlan3已经可以正常通信

gd又可以1美元买域名喽

分类:网站运营日期:2010-11-19 - 12:41:28评论:6条作者:老谢

优惠码:GOBBLE

优惠内容: .COM, .US, .MOBI, .BIZ, .NET, .ORG,

.CA, .CO.UK and .IN仅为1.00美元的域名!

 

第一年的新的注册或转移登记仅适用。此优惠不得用于续费

 

到期时间:

10,000 redemptions or on December 15, 2010 (whichever comes first)

Tags:

三层交换机作用

分类:网络技术日期:2010-11-17 - 22:06:30评论:3条作者:老谢

什么是三层?

三层就是说工作在osi模型第三层的交换机

也就是网络层

三层交换机既然工作在网络层,肯定具有网络层的功能,也就是路由

为什么要使用三层交换机?vlan见的通信必须通过三层交换机来进行。

三次交换机的作用

三层交换机的优势:具有路由的功能,具有交换机的性能

更多三层交换机知识:http://baike.baidu.com/view/44586.htm

冲突域和广播域

分类:网络技术日期:2010-11-15 - 12:50:40评论:5条作者:老谢

广播域

如图所示,这个网络里面,总共四台交换机

这里面包含多少冲突域和广播域呢?

这里面只有一个广播域,但有十个冲突域

判断几个广播域几个冲突域很简单

  • 每个vlan是一个广播域
  • 交换机每个端口是冲突域
  • 交换机之间互连是一个冲突域

在理解之前,大家还是把冲突域和广播域理解清楚

交换机:只可以分隔冲突域,不能分隔广播域

路由器:可以分隔广播域

冲突只有在hub里面存在,可以理解为一个人说话,其他人都需要等待他说完才可以发言,机器越多,排队时间越长,所以最造成网络阻塞,而交换机则可以独立开来,各自说各自的,不用等他人发言完毕就可以说话。