日历存档: 2011 年 9 月 25 日

@TQY

分类:程序设计日期:2011-09-25 - 20:23:03评论:10条作者:老谢

【问题描述】编写一个程序实现如下功能:接收用户输入的某个字符,判别该字符是不是英文字母(区分大小写),如果是字母,则输出它在字母表中对称位置的字母,例如输入a则输出z,输入B则输出Y。若该字符不是英文字母则报告显示”it is not a letter”字样。 (注意编程时不要有多余的提示语句,如:请输入字符之类)
【输入形式】一个英文字母
【输出形式】参见样例:对称的字母
【样例输入】a
【样例输出】z

【样例输入】B
【样例输出】Y

#include<iostream>
using namespace std;
int main()
{
char a,b;
     {
      cin>>a;
      if(a<65||a>90&&a<97||a>122) cout<<"it is not a letter"<<endl;
      else if(a>=97&&a<=122) {b=219-a;cout<<b<<endl;
      }
else {b=155-a;cout<<b<<endl;}}
return 0;
}

得分10.0 最后一次提交时间:2011-09-25 18:42:15

共有测试数据:3
平均占用内存:44.376K 平均运行时间:0.487S

测试数据 评判结果
测试数据1 完全正确
测试数据2 完全正确
测试数据3 完全正确

【问题描述】

根据以下函数关系编写程序,对输入的每个x值,计算出相应的y值。

 x
y
x<0
|x|
0<x<10
x2
x>=10
3开平方根)( x

【输入形式】x,y定义为double型
【输出形式】参见样例
【样例输入】-2.6
【样例输出】2.6

【样例输入】3.14
【样例输出】9.8596

【样例输入】12.46
【样例输出】43.9822

#include <iostream>
#include <math.h>
 
using namespace std;
int main()
{
double x,y;
y=0;
cin>>x;
if (x<0) // x<0 |x| 
{ 
  y=fabs(x); 
} 
else if (x<10&&x>0)// 0<x<10 x2 
{
  y=x*x;
}
else if (x>=10)// x>=10 3开平方根)( x 
{
  y=powsqrt(x),3;
}
cout<<y<<endl;
}

得分20.0 最后一次提交时间:2011-09-25 20:06:02

共有测试数据:3
平均占用内存:30.564K 平均运行时间:0.273S

测试数据 评判结果
测试数据1 完全正确
测试数据2 完全正确
测试数据3 完全正确

【问题描述】
服装店经营套服,也单件出售。若买的不少于50套, 每套80元;不足50套的每套90元;只买上衣每件60元;只买裤子则每条45元。从键盘输入需要购买的上衣数c和裤子数t,编写程序计算购买衣服的应付款数额m。
【输入形式】输入两个整数分别表示上衣数c和裤子数t,以空格作分隔符
【输出形式】应付款项m
【样例输入】40 60
【样例输出】4500

【样例输入】60 40
【样例输出】4800

【样例输入】70 60
【样例输出】5400

【样例输入】60 70
【样例输出】5250

#include "iostream.h"
int main()
{
 int yi,ku,xiao,w;
cin>>yi>>ku;
 if(yi>ku) w=60*(yi-ku);
 else w=45*(ku-yi);
 xiao=(yi>ku)? ku:yi;
 if(xiao>=50){
  w=xiao*80+w;
 }
 else w=xiao*90+w;
 cout<<"\n"<<w;
}

得分20.0 最后一次提交时间:2011-09-25 21:21:52
成功编译,但有警告信息.
In file included from /usr/lib/gcc/x86_64-redhat-linux/4.1.2/../../../../include/c++/4.1.2/backward/iostream.h:31,
from ___1.cpp:1:
/usr/lib/gcc/x86_64-redhat-linux/4.1.2/../../../../include/c++/4.1.2/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header. Please consider using one of the 32 headers found in section 17.4.1.2 of the C++ standard. Examples include substituting the header for the header for C++ includes, or instead of the deprecated header . To disable this warning use -Wno-deprecated.
共有测试数据:4
平均占用内存:28.554K 平均运行时间:0.301S

测试数据 评判结果
测试数据1 完全正确
测试数据2 完全正确
测试数据3 完全正确
测试数据4 完全正确

选择题部分

4:选择A n无法取值
6:a==2*n 100%选D了……
8:n++使用后执行+操作,++n使用前就执行+操作 故选择B

ps:我检查觉得无误了,你找你同学对对答案吧,祝你好运,亲。

Who

分类:乱七八糟日期:2011-09-25 - 13:37:02评论:2条作者:老谢

Who