日志标签:cisco

EVE-NG模拟器基本配置及关联SecureCRT、Wireshark及VNC

分类:网络技术日期:2018-04-02 - 21:03:59评论:0条作者:老谢

  EVE-NG(全称Emulated Virtual Environment – NextGeneration),继Unetlab 1.0后的Unetlab的2.0新版本,改了名字,原名是UnifiedNetworking Lab统一网络实验室。笔者觉得名字改的非常合理,这款模拟器已经不仅可以模拟网络设备,也可以运行一切虚拟机。理论上,只要能将虚拟机的虚拟磁盘格式转换为qcow2都可以在EVE-NG上运行。所以,EVE-NG可以算得上是仿真虚拟环境。EVE-NG是国外大神们开发的,融合了dynamips,IOL,KVM。它是深度定制的Ubuntu操作系统,可以直接把它安装在x86架构的物理主机上。它也有ova版本,可以导入到VMware等虚拟机软件中运行。EVE-NG在交互模式上更加具有优势,与GNS3截然不同。GNS3更像是用户使用的软件,只有GNS3支持的 OS才能使用;而EVE-NG更像是CS模型,EVE-NG是服务端,用户端可以是支持http/https的任意OS。

EVE-NG模拟器的安装配置

  可以在EVE-NG官网下载到ova格式的虚拟机文件,在VMware Workstation Pro或VSPHERE等虚拟机中导入即可,root的默认密码是eve,老版本可能是unl,第一次进入系统会进入初始化配置界面,按照向导进行设置即可,之后会自动进行重启,再次进入系统可以使用apt-get update获取更新列表,然后使用apt-get install eve-ng安装eve-ng的更新版本。

  使用vim将下面的python脚本写到文件,然后使用命令pydoc3 文件名执行后即可进行破解并自动写入序列号。

CiscoIOUKeygen.py
#! /usr/bin/python
print("*********************************************************************")
print("Cisco IOU License Generator - Kal 2011, python port of 2006 C version")
print("Modified to work with python3 by c_d 2014")
import os
import socket
import hashlib
import struct
 
# get the host id and host name to calculate the hostkey
hostid=os.popen("hostid").read().strip()
hostname = socket.gethostname()
ioukey=int(hostid,16)
for x in hostname:
 ioukey = ioukey + ord(x)
print("hostid=" + hostid +", hostname="+ hostname + ", ioukey=" + hex(ioukey)[2:])
 
# create the license using md5sum
iouPad1 = b'\x4B\x58\x21\x81\x56\x7B\x0D\xF3\x21\x43\x9B\x7E\xAC\x1D\xE6\x8A'
iouPad2 = b'\x80' + 39*b'\0'
md5input=iouPad1 + iouPad2 + struct.pack('!I', ioukey) + iouPad1
iouLicense=hashlib.md5(md5input).hexdigest()[:16]
 
print("\nAdd the following text to ~/.iourc:")
print("[license]\n" + hostname + " = " + iouLicense + ";\n")
print("You can disable the phone home feature with something like:")
print(" echo '127.0.0.127 xml.cisco.com' >> /etc/hosts\n")
 
 
lic = ["[license]\n" + hostname + " = " + iouLicense + ";" + "\n"]
f = open('/opt/unetlab/addons/iol/bin/iourc','w')
f.writelines(lic)
f.close()

继续阅读…

Tags: , ,

OSPF学习之LSA类型

分类:思科技术日期:2012-05-19 - 20:06:38评论:11条作者:老谢

试验拓扑:

OSPF学习之LSA类型

继续阅读…

Tags: , ,

EIGRP学习总结

分类:思科技术日期:2012-05-17 - 21:34:26评论:13条作者:老谢

试验拓扑:

EIGRP学习总结

继续阅读…

Tags: ,

Cisco Help Address试验

分类:思科技术日期:2012-05-16 - 9:23:45评论:9条作者:老谢

拓扑如下:

Cisco Help Address试验

实验目的:由2.0网段的HDCP服务器为1.0网段的DHCP客户端分配ip地址。

DCHP_Client(config)#int e 0/0
DCHP_Client(config-if)#ip address dhcp 
DCHP_Client(config-if)#no shut
R1(config)#int e 0/0
R1(config-if)#ip add 192.168.1.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#int e 0/1
R1(config-if)#ip add 192.168.2.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#int e 0/0
R1(config-if)#ip helper-address 192.168.2.2
HDCP_Server(config)#int e 0/0
HDCP_Server(config-if)#ip add 192.168.2.2 255.255.255.0
HDCP_Server(config-if)#no shut
HDCP_Server(config-if)#exit
HDCP_Server(config)#ip dhcp pool test 
HDCP_Server(dhcp-config)#network 192.168.1.0 /24
HDCP_Server(dhcp-config)#default-router 192.168.1.1
HDCP_Server(dhcp-config)#exit
HDCP_Server(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.10
HDCP_Server(config)#end
DCP_Server#conf t
HDCP_Server(config)#ip route 192.168.1.0 255.255.255.0 ethernet 0/0

配置完以后,十几秒就会看到模拟客户端的路由器出现下面的提示:

DCHP_Client#Interface Ethernet0/0 assigned DHCP address 192.168.1.11, mask 255.255.255.0

已经成功获取到了192.168.1.11这个地址。

Tags: ,

dynamips的net文件详解

分类:网络技术日期:2011-09-02 - 21:42:12评论:0条作者:老谢

今天计划制作一个虚拟实验室,以后可以很方便的使用,所以开始接触dynamips的脚本编写

小弟找了很多资料,写了下面一个脚本的注释版,希望可以对跟我一样的新手朋友有帮助

autostart = False  //所有设备默认不启动,如果设置为ture为打开后启动全部设备,建议设为false
 
[localhost]
port = 7200
udp = 10000   //设置所有的虚拟设备使用的端口号
 
workingdir = ..\tmp\  //设置存放dynamips工作文件的目录
 
 
[[3620]] //设置路由型号为3620
ram = 26 //设置内存大小,尽量适合自己,太小启动不了设备,太大浪费
image = ..\ios\unzip-c3620-i-mz.122-37.bin //设置ios路径
slot0 = NM-4T  //接口模块
slot1 = NM-4E  //接口模块
idlepc = 0x60371394 //这个数值影响了程序的性能,最好多试几个
mmap = False //如何内存够大可以设置为ture,完全运行在内存,现在内存一般4G足够了
confreg = 0x2142 //默认寄存器值
 
        [[ROUTER R1]]
	model = 3620
	console = 2001
        E1/0 = S1 1
 
//model定义设备类型为3620
//console口的端口为2001
//E1/0口连接s1的1口  下同
 
 
 
        [[ROUTER R2]]
	model = 3620
	console = 2002
        S0/0 = R1 S0/0
        S0/1 = R3 S0/1
        S0/2 = R3 S0/2
        E1/0 = S1 2
 
 
 
 
        [[ROUTER R3]]
	model = 3620
	console = 2003
        E1/0 = S1 3
 
 
 
  [[ethsw S1]]
    1 = access 1
    2 = access 1
    3 = access 1
Tags: ,

二层交换机每个端口有没有MAC地址

分类:思科技术日期:2011-07-29 - 11:17:01评论:12条作者:老谢

今天在一个思科学习群里面看到一个朋友问交换机的每个端口有没有MAC地址

我都第一反应是没有MAC,交换机的MAC是学来的,有一张MAC表来维护

但是有朋友反问,那STP等选举用哪个MAC来选举呢?好吧,无言以对了,开始google

搜了一篇文章以后明白了,二层交换机有一个基本MAC,该MAC可以show version看到

Switch#show version
Cisco IOS Software, C2960 Software (C2960-LANBASE-M), Version 12.2(25)FX, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2005 by Cisco Systems, Inc.
Compiled Wed 12-Oct-05 22:05 by pt_team

ROM: C2960 Boot Loader (C2960-HBOOT-M) Version 12.2(25r)FX, RELEASE SOFTWARE (fc4)

System returned to ROM by power-on

Cisco WS-C2960-24TT (RC32300) processor (revision C0) with 21039K bytes of memory.

24 FastEthernet/IEEE 802.3 interface(s)
2 Gigabit Ethernet/IEEE 802.3 interface(s)

64K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address       : 00E0.B0E7.349C
Motherboard assembly number     : 73-9832-06
Power supply part number        : 341-0097-02
Motherboard serial number       : FOC103248MJ
Power supply serial number      : DCA102133JA
Model revision number           : B0
Motherboard revision number     : C0
Model number                    : WS-C2960-24TT
System serial number            : FOC1033Z1EY
Top Assembly Part Number        : 800-26671-02
Top Assembly Revision Number    : B0
Version ID                      : V02
CLEI Code Number                : COM3K00BRA
Hardware Board Revision Number  : 0x01

Switch   Ports  Model              SW Version              SW Image
——   —–  —–              ———-              ———-
*    1   26     WS-C2960-24TT      12.2                    C2960-LANBASE-M

Configuration register is 0xF

图中可以看到,有个基本MAC,这个MAC用于STP选举,而且这个MAC一般会在交换机的标签上说明,可以找找看有木有这个MAC地址

至于每个端口的MAC,可以用show int来查看

创建VLAN路由以后,VLAN的虚拟接口会创建另一个地址,所有VLAN的虚拟接口都使用这个地址。这个地址通常是设备MAC地址+1或者+2。

交换机有一个MAC地址池,一般交换机都有几十个到几百个MAC地址,给每个端口都会分配一个。
这些MAC都是连续的,生成树中的组成交换机ID的MAC一般是VLAN 1的MAC。

交换机的每个端口都有各自的mac地址!
#show int
得到结果是:
交换机的每个端口都有各自的mac地址,而且是逐个加一,
例如:如果交换机的mac地址是000d0.0000.0000.
那么,e0/1 的mac地址为00d0.0000.0001
         e0/2的mac地址为00d0.0000.0002

二层交换机属于数据链路层设备,每个交换机端口都有MAC地址,一个交换机内的所有Ethernet端口的MAC是连续的。二层交换机不具备三层设备的路有功能,但是可以配置1个telnet ip,便于配置管理

三层交换机 路由器的每个端口都有MAC地址,每个端口都可以配ip

——————————————————————————–

为了弄清楚二层交换机的端口MAC作用,继续搜索。。。。。

思科的一句原文

For L2 switches, there are mac addresses for different functions (to be able to communicate (when we want to telnet, ping or do snmp to the switch) and spanning tree (to form the bridge ID).

但是事实上很多交换机不只一个MAC地址,而是每个端口均有一个MAC地址,这个就与Spanning Tree生成树协议有关

运行生成树协议的交换机会发送BPDU获取Bridge ID,Bridge ID中包括网桥的优先级和网桥MAC地址,Bridge ID最小者当选根网桥,在选举出根网桥之后,Spanning Tree协议会在非根网桥选取唯一的根端口,这时就与端口的Port ID相关,在实际应用中是以端口的MAC地址作为Port ID。这就是端口MAC地址的用处之在。实际表现的形式就是交换机本地报文的二层封装,如BPDU。

至于Port ID为何要以MAC地址而不由交换机自定义,我个人的想法是这个原因和网卡MAC地址使用网卡物理地址的原因类似,Port ID要求标识出哪个网桥的哪个端口,使用Bridge ID+Port ID就可以在全网唯一标识一个端口,那采用何种地址方能保证唯一?自然就是MAC地址。

查阅了一些资料,实际上在思科的交换机中端口1存在一个MAC地址,之后的端口依次将1的MAC地址加1作为本端口的MAC。

———————————————————————————

下面是交换机MAC的问题于CCIE的一段对话

交谈中请勿轻信汇款、中奖信息、陌生电话,勿使用外挂软件。

查扣  11:45:46

  二层交换机 照理没有物理口mac

查扣  11:45:55

   有的话肯定也是真实的

夏日。  11:46:50

如果没有MAC 那STP如何选举根端口呢?

查扣  11:47:13

stp 的mac是交换机的mac

夏日。  11:47:46

交换机本身只有一个MAC吧 所有的选举都用这一个MAC?

查扣  11:47:56

  是啊

夏日。  11:48:05

根桥 根端口 指定端口 都用这一个MAC?

查扣  11:48:26

    优先级 交换机的mac  端口号 端口优先级,就这些因素吧

查扣  11:48:44

   是啊

查扣  11:48:51

  mac都是指交换机的桥maac

夏日。  11:49:03

端口ID不就是 端口优先级+MAC

夏日。  11:49:27

但是我show int每个端口 发现有自己不同的MAC 是什么情况

查扣  11:49:48

   那也有可能,端口mac一般是桥mac 好像尾数上加上去

查扣  11:49:56

  选跟桥用的肯定是交换机mac

夏日。  11:50:15

桥选举肯定用交换机的MAC没错 我现在疑惑就是端口的MAC

夏日。  11:50:40

那你的意思就是说 交换机的端口有MAC 尾数加上去 这个MAC是虚拟的 而不是物理的?

查扣  11:51:30

   怎么定义虚拟物理

查扣  11:51:44

    这个mac在二层环境是没有意义的

夏日。  11:52:19

我刚刚搜了一下相关的文章说 二层有一个地址池的概念

夏日。  11:53:03

虚拟和物理 我刚刚应该理解错了 网卡的MAC是物理烧制进去的 而交换机的端口MAC可以从地址池获取?

查扣  11:55:19

    mac哪来的获取

夏日。  11:56:15

交换机有一个MAC地址池,一般交换机都有几十个到几百个MAC地址,给每个端口都会分配一个。这些MAC都是连续的,生成树中的组成交换机ID的MAC一般是VLAN 1的MAC。

夏日。  11:56:21

找到的一篇文章的原话

查扣  11:56:35

    就是啊,指的就是交换机的 id

夏日。  11:57:17

这意思不还是 每个端口有一个属于自己的MAC么?

查扣  11:57:19

    生成树里,有root id 就是选出来的 跟桥mac 还有个 bri id 就是本交换机id

查扣  11:57:24

  还有一个cost

查扣  11:57:37

   还有一个 port id 这个你就当时端口序号就可以

查扣  11:58:37

    所谓的端口id就是 根据桥id开始往后自低往高 加1,给上去,无实际意义,只是标示意义

夏日。  11:58:40

哦 就是说每个端口是有MAC来参与计算port id的

夏日。  11:59:20

明白了

查扣  11:59:24

   你也可以理解为 有个mac

夏日。  11:59:43

嗯,理解了 基本根桥ID+1

查扣  11:59:40

   但是计算的时候前面部分相同,实际就是比的最后的,那相当于端口序号

查扣  12:00:02

   而在通讯中,这个端口所谓的mac是无任何意义的

查扣  12:00:08

    在二层概念里

夏日。  12:00:14

嗯 明白

查扣  12:00:17

  当然你三层后,就有意义了

夏日。  12:00:50

那如果划VLAN的话 配置IP 它用哪个MAC呢?

查扣  12:01:35

    划了vlan,自然就是用vlan接口的mac

夏日。  12:02:03

这个VLAN接口的MAC就是交换机本身的MAC+1得到的?

查扣  12:02:11

    你去观察下三层交换机 划几个vlan 这几个vlan 接口的mac有什么特点,你就知道了

夏日。  12:03:01

我是说在二层划VLAN的情况下

查扣  12:03:16

   一样

查扣  12:03:29

    所有vlan的svi接口的mac都一样

查扣  12:03:39

   也就是交换机的 mac

查扣  12:04:04

     所以没啥vlan1 地址这一说

查扣  12:04:11

  vlan2 有地址 mac也是这个

夏日。  12:04:26

svi接口?

查扣  12:04:28

    是哦

查扣  12:04:36

svi 就是 通俗说的vlan接口

夏日。  12:04:49

查扣  12:05:05

   所以他说桥id是vlan1 的mac 不完全确切

查扣  12:05:11

  所有vlan的mac都是这个

查扣  12:05:22

    倒过来理解才对

查扣  12:05:30

    交换机有一个桥id 本身有的

查扣  12:05:42

    交换机上起vlan,默认就借的这个mac

查扣  12:05:45

   是这样的逻辑

夏日。  12:07:01

所有VLAN用同一个MAC 最后确切找到这个VLAN使用IP来找?

查扣  12:07:25

  每个vlan 就是一个广播域,本身各个vlan都是隔开的

查扣  12:07:29

     所以无所谓

查扣  12:07:43

在vlan1的广播域里,这个mac是唯一的

查扣  12:08:10

    通信的时候还是按照arp来找

查扣  12:08:56

    即使不在一个广播域,问题也不大

夏日。  12:09:12

如果划分多个VLAN 比如VLAN10 VLAN20 都用同样的MAC 那么三层设备如何区分这两个广播域?

查扣  12:09:10

  因为这其实是在同一个物理主体上的一个mac

查扣  12:09:25

    你换个方法想

查扣  12:09:42

   不想交换机,就想电脑网卡

查扣  12:09:48

    一个网卡不是可以多个ip吗

查扣  12:09:54

   那不等于多个ip有一个mac

查扣  12:09:57

  不照样能路由

查扣  12:10:37

    数据包只需要正确到这个位置,然后查路由表再封装出去就可以

查扣  12:10:39

  没任何问题

查扣  12:11:16

这样应该想得通了吧,呵呵

夏日。  12:12:49

比如VLAN10的网段是192.168.1.0 VLAN20是192.168.2.0 发进来的包是192.168.2.0这个网络 VLAN1就会丢弃?

查扣  12:13:53

vlan1 ?又没关vlan1的事

夏日。  12:14:14

错了 其他VLAN就会丢弃么

查扣  12:14:27

  数据包到了既然从vlan20的 进入,就只能到vlan20的svi哦

夏日。  12:15:17

二层没有IP的概念 其他网段根本收不到  是吧

查扣  12:15:52

   你通讯的基础是ip。你发一个请求 问2.1 这个的arp,人家回应为aaaaaaa

查扣  12:15:58

  你就往这个mac发

查扣  12:16:14

   你这个 网络有这个mac的就收,只要这个mac上有这个2.1的地址

夏日。  12:16:48

明白了!

夏日。  12:17:08

谢谢查扣啊 耽误你这么久的时间  终于理解了

查扣  12:17:15

   呵呵

夏日。  12:17:26

查扣  12:17:27

  假如这个mac上没有2,1的地址,第一个arp也不会回应

查扣  12:17:31

所以必然会收哦

查扣  12:17:32

呵呵

夏日。  12:17:39

嗯 明白

查扣  12:17:51

   哦

夏日。  12:17:55

非常感谢查扣的耐心解答

查扣  12:17:58

夏日。  12:18:13

那你先忙,不打扰了哈~

查扣  12:18:14

老谢总结:交换机有一个基本MAC,PID=BID+1 所有VLAN都用同一个MAC 可以理解为一张网卡配置多个IP

尼玛的cisco!640-802题库笔记(持续更新)

分类:思科技术日期:2011-07-08 - 21:05:16评论:5条作者:老谢

尼玛的cisco!640-802题库笔记(持续更新)

一天至少理解5、60题吧!!好吧,今天开始开工了!!!

ps:本文除原英文题外,所有汉字部分,均为老谢原创,转载请注明!

本人英语很垃圾,只能解释大意,较真的朋友就完全没必要了

1. Refer to the exhibit. What could be possible causes for the "Serial0/0 is down" interface status? (Choose two.)

大意:如果所示s0/0的端口状态,可能的原因是什么

尼玛的cisco!640-802题库笔记(持续更新)

A. A Layer 1 problem exists. 第一层有问题,嗯。。。正确
B. The bandwidth is set too low. 带宽设置错误?坑爹啊!
C. A protocol mismatch exists. 协议不匹配?肯定不对。。
D. An incorrect cable is being used. 使用不匹配的线缆类型,对的。。
E. There is an incorrect IP address on the Serial 0/0 interface. IP地址?尼玛show int关你IP什么事

本题答案:AD

2. Before installing a new, upgraded version of the IOS, what should be checked on the router, and which
command should be used to gather this information? (Choose two.)

大意:升级IOS,应该检查什么

A. the amount of available ROM 检查ROM,那flash不检查了?
B. the amount of available flash and RAM memory ROM、flash都有了,正确
C. the version of the bootstrap software present on the router 看bootstrap版本?有必要么
D. show version 看目前IOS的版本,有必要,正确
E. show processes 管你进程什么事。
F. show running-config 看你妹的运行配置。。

本题答案:BD

3. Refer to the exhibit. Which two statements are true about interVLAN routing in the topology that is shown in the exhibit? (Choose two.)

尼玛的cisco!640-802题库笔记(持续更新)

大意:看拓扑,哪两种说法正确在这个vlan间路由

A. Host E and host F use the same IP gateway address. E去F用相同的网关,肯定不对了
B. Router1 and Switch2 should be connected via a crossover cable. 路由连接交换机用交叉线?错了!
C. Router1 will not play a role in communications between host A and host D. router1在A和D通信不起到任何作用?怎么可能呢。。
D. The FastEthernet 0/0 interface on Router1 must be configured with subinterfaces. 单臂路由,配置子接口,正确
E. Router1 needs more LAN interfaces to accommodate the VLANs that are shown in the exhibit.  route1需要更多lan来连接如图所示的vlan们,你们家接口不要钱吧!!配置子接口就行了!

F. The FastEthernet 0/0 interface on Router1 and Switch2 trunk ports must be configured using the same encapsulation type. 使用相同的封装类型,正确

本题答案:EF

4. Refer to the exhibit. Which two statements are true about the loopback address that is configured on RouterB? (Choose two.)

尼玛的cisco!640-802题库笔记(持续更新)

大意:选择两种关于loopback口的正确说法

A. It ensures that data will be forwarded by RouterB.  routerB为什么要转发数据。。。
B. It provides stability for the OSPF process on RouterB. 可以稳定OSPF进程,嗯,正确
C. It specifies that the router ID for RouterB should be 10.0.0.1. 嗯,routerB的路由ID是loopback口
D.It decreases the metric for routes that are advertised from RouterB. 可以改变度量值?怎么可能。。

E. It indicates that RouterB should be elected the DR for the LAN. routerB的路由ID最大?明显不是,怎么可能当选DR呢!!

答案:BC

5. A network administrator is explaining VTP configuration to a new technician. What should the network
administrator tell the new technician about VTP configuration? (Choose three.)

大意:新来的一个网管,告诉新网管VTP的配置
A switch in the VTP client mode cannot update its local VLAN database.

client不能更新自己的vlan,正确
B. A trunk link must be configured between the switches to forward VTP updates.

trunk链路必须转发更新VTP的信息,正确
A switch in the VTP server mode can update a switch in the VTP transparent mode.

尼玛人家都透明模式了,你server还更新你妹啊!不对!
D. A switch in the VTP transparent mode will forward updates that it receives to other switches.
透明模式可以转发vtp更新,正确,我不学习但是转发,我就是个传话的

E. A switch in the VTP server mode only updates switches in the VTP client mode that have a higher VTP
revision number.

server只能从client学更高版本的VTP??显然不对。。
F. A switch in the VTP server mode will update switches in the VTP client mode regardless of the configured VTP domain membership.

不管配没配vtp域,server都从client更新,又错了。。

答案:ABD

6. Which two locations can be configured as a source for the IOS image in the boot system command?
(Choose two.)

大意:可以启动IOS的位置

A. RAM
B. NVRAM
C. flash memory
D. HTTP server
E. TFTP server
F. Telnet

这题都要翻译的话。。没话说了

答案:CE

7. What are two reasons a network administrator would use CDP? (Choose two.)

大意:网管使用CDP的原因是什么

A. to verify the type of cable interconnecting two devices

验证线缆类型,CDP没这功能
B. to determine the status of network services on a remote deviceC. to obtain VLAN information from directly connected switches

看到network就不用看了,CDP只是本地生效
C. to obtain VLAN information from directly connected switches

CDP不能看到VLAN信息,就是这样

D. to verify Layer 2 connectivity between two devices when Layer 3 fails

可以验证2、3之间的设备,正确

E. to obtain the IP address of a connected device in order to telnet to the device

可以看到连接和telnet的设备,嗯,正确

F. to determine the status of the routing protocols between directly connected routers

可以看到路由协议的情况,这好像是show protocol的功能

答案:DE

8. Refer to the exhibit. Both switches are using a default configuration. Which two destination addresses will host 4 use to send data to host 1? (Choose two.)

尼玛的cisco!640-802题库笔记(持续更新)

A. the IP address of host 1
B. the IP address of host 4
C. the MAC address of host 1
D. the MAC address of host 4
E. the MAC address of the Fa0/0 interface of the R1 router
F. the MAC address of the Fa0/1 interface of the R1 router

大意:4和1都用默认网关,将用什么地址把数据发出去,这个简单的不用讲了

答案:AF

9. Refer to the exhibit. The router has been configured with these commands:

hostname Gateway
interface FastEthernet 0/0
ip address 198.133.219.14 255.255.255.248
no shutdown
interface FastEthernet 0/1
ip address 192.168.10.254 255.255.255.0
no shutdown
interface Serial 0/0
ip address 64.100.0.2 255.255.255.252
no shutdown
ip route 0.0.0.0 0.0.0.0 64.100.0.1
What are the two results of this configuration? (Choose two.)

大意:如图所示,这个路由的配置如下

尼玛的cisco!640-802题库笔记(持续更新)

A. The default route should have a next hop address of 64.100.0.3. 没任何一个地方说明有0.3这个网络
B. Hosts on the LAN that is connected to FastEthernet 0/1 are using public IP addressing. 自己去看配置,FA0/1是一个私网地址
C. The address of the subnet segment with the WWW server will support seven more servers. 这个子网支持超过7个服务器,/29 这样的话主机位就是3,2的3次幂=8,再减掉2=6,明显不对了。。。
D. The addressing scheme allows users on the Internet to access the WWW server. www服务器允许公网直接访问,嗯。。正确,它使用公网IP
E. Hosts on the LAN that is connected to FastEthernet 0/1 will not be able to access the Internet without
address translation.   在没有地址转换的情况下,fa0/1不能访问互联网,正确

答案:ED

10. A company is installing IP phones. The phones and office computers connect to the same device. To ensure maximum throughput for the phone data, the company needs to make sure that the phone traffic is on a different network from that of the office computer data traffic. What is the best network device to which to directly connect the phones and computers, and what technology should be implemented on this device?
(Choose two.)

大意:公司装IP电话,为了确保不同的流量,应该用什么设备和什么技术
A.hub
B. router
C. switch
D. STP
E. subinterfaces
F. VLAN

简单的题目我也就不浪费时间说了

答案:CF

11. What are two benefits of using VTP in a switching environment? (Choose two.)
大意:在交换网络中使用VTP的两个好处

A. It allows switches to read frame tags. 允许读取帧标签,不正确
B. It allows ports to be assigned to VLANs automatically. 端口被自动分配到对应vlan,肯定不对,要是正确就乱套了
C. It maintains VLAN consistency across a switched network. 保持整个网络的VLAN一致性,正确
D. It allows frames from multiple VLANs to use a single interface. 允许多个vlan使用单一接口,不对

E. It allows VLAN information to be automatically propagated throughout the switching environment. 允许VLAN信息自动传播到网络

答案:CE

12. Which two statements are true about the command ip route 172.16.3.0 255.255.255.0 192.168.2.4?
(Choose two.)

大意:下面哪两种关于这条命令正确的说法

A. It establishes a static route to the 172.16.3.0 network. 建立了3.0的静态路由,正确
B. It establishes a static route to the 192.168.2.0 network. 哪里有2.0这个网络,明显不对
C. It configures the router to send any traffic for an unknown destination to the 172.16.3.0 network. 一条未知的路由将发送到3.0这个网络,不能嘛,这又不是默认路由
D. It configures the router to send any traffic for an unknown destination out the interface with the address
192.168.2.4. 跟上个选项大意差不多
E. It uses the default administrative distance. 使用默认管理距离 正确
F. It is a route that would be used last if other routes to the same destination exist. 存在其他路由的时候,使用其他路由条目,不可能吧,默认路由的管理距离最高

答案:AE

13. What are two advantages of Layer 2 Ethernet switches over hubs? (Choose two.) 交换机比较集线器的两点优势

A. decreasing the number of collision domains 减少冲突域 错误
B. filtering frames based on MAC addresses 基于MAC过滤 正确
C. allowing simultaneous frame transmissions 允许帧同步发送 正确
D. increasing the size of broadcast domains 增加广播域,错误
E. increasing the maximum length of UTP cabling between devices 增加线缆长度?一毛钱关系都没

答案:BC

14. Refer to the exhibit. A network associate needs to configure the switches and router in the graphic so that the hosts in VLAN3 and VLAN4 can communicate with the enterprise server in VLAN2. Which two Ethernet segments would need to be configured as trunk links? (Choose two.)

大意:如图所示,哪两条线路需要配置trunk

尼玛的cisco!640-802题库笔记(持续更新)

A. A
B. B
C. C
D. D
E. E
F. F

答案:很明显是CF

15. Which two values are used by Spanning Tree Protocol to elect a root bridge? (Choose two.) 哪两种情况会当选成根网桥
A. amount of RAM
B. bridge priority
C. IOS version
D. IP address
E. MAC address
F. speed of the links

答案:BF

16. Refer to the exhibit. Assume that the routing protocol referenced in each choice below is configured with its default settings and the given routing protocol is running on all the routers. Which two conditional statements accurately state the path that will be chosen between networks 10.1.0.0 and 10.3.2.0 for the routing protocol mentioned? (Choose two.)

尼玛的cisco!640-802题库笔记(持续更新)

A. If OSPF is the routing protocol, the path will be from R1 to R3 to R4 to R5.
B. If OSPF is the routing protocol, the path will be from R1 to R2 to R5.
C. If OSPF is the routing protocol, the path will be from R1 to R5.
D. If RIPv2 is the routing protocol, the path will be from R1 to R3 to R4 to R5.
E. If RIPv2 is the routing protocol, the path will be from R1 to R5.

其实问的就是两种不同的路由协议,会如何选取最优路径

答案:AE

17. Refer to the exhibit. A network administrator is adding two new hosts to SwitchA. hich three values could be used for the configuration of these hosts? (Choose three.)

尼玛的cisco!640-802题库笔记(持续更新)

大意:在交换机A下面增加了两台主机,将用到什么配置

A. host A IP address: 192.168.1.79
B. host A IP address: 192.168.1.64
C. host A default gateway: 192.168.1.78
D. host B IP address: 192.168.1.128
E. host B default gateway: 192.168.1.129
F. host B IP address: 192.168.1.190

自己算吧

答案:ACF

18. A network administrator changes the configuration register to 0x2142 and reboots the router. What are two results of making this change? (Choose two.)

大意:网管改变了寄存器值为:0X2142,重启路由器后会有什么变化

A. The IOS image will be ignored. 忽略IOS?成仙了么……
B. The router will prompt to enter initial configuration mode.进去配置模式,嗯,正确
C. The router will boot to ROM. 寄存器跟ROM有什么关系。。
D. Any configuration entries in NVRAM will be ignored. 忽略NVRAM,正确
E. The configuration in flash memory will be booted. 跟flash没关系- –

答案:BD

19. Refer to the exhibit. The networks connected to router R2 have been summarized asa 192.168.176.0/21 route and sent to R1. Which two packet destination addresses will R1 forward to R2? Choose two.)

尼玛的cisco!640-802题库笔记(持续更新)

大意:连接到R2的路由汇总了192.168.176.0/21的路由发给R1 哪两个包R1将发给R2

A. 192.168.194.160
B. 192.168.183.41
C. 192.168.159.2
D. 192.168.183.255
E. 192.168.179.4
F. 192.168.184.45

192.168.10110 000.00000000~192.168.10110 111.11111111 176.1~183.254

答案:BE

20. Which three statements are typical characteristics of VLAN arrangements?(Choosethree.)

大意:关于VLAN的三种典型特征
A. A new switch has no VLANs configured. 默认VLAN1,所以错误

B. Connectivity between VLANs requires a Layer 3 device. VLAN间路由需要三层设备,正确
C. VLANs typically decrease the number of collision domains. VLAN减少冲突域,错误
D. Each VLAN uses a separate address space. 每一个VLAN使用单独的地址 正确
E. A switch maintains a separate bridging table for each VLAN. 每个VLAN都有一张表,正确
F. VLANs cannot span multiple switches. VLAN不能传播到其他交换机(用VLAN实现)

答案:BDE

21. Refer to the exhibit. Which three statements are true about how router JAX will choose a path to the 10.1.3.0/24 network when different routing protocols are configured? (Choose three.)

尼玛的cisco!640-802题库笔记(持续更新)

A. By default, if RIPv2 is the routing protocol, only the path JAX-ORL will be installed into the routing table.
B. The equal cost paths JAX-CHI-ORL and JAX-NY-ORL will be installed in the routing table if RIPv2 is the
routing protocol.
C. When EIGRP is the routing protocol, only the path JAX-ORL will be installed in the routing table by
default.
D. When EIGRP is the routing protocol, the equal cost paths JAX-CHI-ORL, and JAX-NY-ORL will be
installed in the routing table by default.
E. With EIGRP and OSPF both running on the network with their default configurations, the EIGRP paths
will be installed in the routing table.
F. The OSPF paths will be installed in the routing table, if EIGRP and OSPF are both running on the
network with their default configurations.

大意:两种路由协议,如何选择路径

答案:ADE

Tags: ,

PPP试验笔记

分类:思科技术日期:2011-07-04 - 22:00:08评论:22条作者:老谢

PPP试验笔记

PAP验证试验

在R1和R2上做相同的配置

R1(config)#int s 0/0
R1(config-if)#encapsulation ppp

在R1上配置用户名和密码和认证方式

R1(config)#username laoxie password 123

R1(config-if)#ppp authentication pap

被认证方上配置需要发送的密码

R2(config)#int s 0/0
R2(config-if)#ppp pap sent-username laoxie password 123

 认证经历两次握手,由被认证方发起请求

——————————————–

CHAP认证试验

R1(config-if)#ppp authentication chap
R1(config-if)#exit  
R1(config)#username user1 password 123
R1(config-if)#ppp chap hostname user2

R2(config)#username r2 password 123
R2(config)#int s 0/0
R2(config-if)#ppp chap hostname r1

PS:chap 如果没有指定发送用户名,发送路由器的名称

——————————————–

IP协商

R2(config-if)#ip add negotiated

R2在端口上配置协商模式

R1(config-if)#peer default ip address 192.168.1.10

PPP试验笔记

——————————————–

压缩试验 | 命令如下

ip tcp header-compression //TCP头部压缩

compress stac //数据压缩

show一下效果

R1#show compress   
Serial0/0
         Software compression enabled
         uncompressed bytes xmt/rcv 817/817
         compressed bytes   xmt/rcv 405/413
         Compressed bytes sent:       405 bytes   0 Kbits/sec  ratio: 2.017
         Compressed bytes recv:       413 bytes   0 Kbits/sec  ratio: 1.978
         1  min avg ratio xmt/rcv 0.512/0.520
         5  min avg ratio xmt/rcv 0.512/0.520
         10 min avg ratio xmt/rcv 0.512/0.520
         no bufs xmt 0 no bufs rcv 0
         resyncs 0
         Additional Stac Stats:
         Transmit bytes:  Uncompressed =        0 Compressed =        405
         Received bytes:  Compressed =        419 Uncompressed =        0

Tags: ,

ACL试验题

分类:思科技术日期:2011-07-03 - 21:19:02评论:4条作者:老谢

ACL试验题

在Corp配置,因为要求不能访问web服务器,所以要用扩展访问列表,下面开始配置

注意:特权模式密码是cisco

Router>en
Password: 
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#access-list 100 permit tcp host 192.168.33.4 host 172.22.242.23 eq 80
Router(config)#access-list 100 deny tcp any host 172.22.242.23 eq 80
Router(config)#access-list 100 permit ip any any 
Router(config)#do show ip int b
Interface              IP-Address      OK? Method Status                Protocol
 
FastEthernet0/0        192.168.33.254  YES manual up                    up
 
FastEthernet0/1        172.22.242.30   YES manual up                    up
 
Serial1/0              198.18.247.65   YES manual up                    up
 
Serial1/1              unassigned      YES unset  administratively down down
 
Serial1/2              unassigned      YES unset  administratively down down
 
Serial1/3              unassigned      YES unset  administratively down down
 
Vlan1                  unassigned      YES unset  administratively down down
Router(config)#int fa 0/1
Router(config-if)#ip access-group 100 out 
Router(config-if)#end
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router#
Router#copy run start
Destination filename [startup-config]? 
Building configuration...
[OK]
Router#
Router#

测试一下ACL是否正常,最后记得保存,一定要保存

最后发泄一句:尼玛的ACL,尼玛的OSPF,尼玛的EIGRP,尼玛的cisco,尼玛的英文考卷,尼玛的….题库看的抓狂….

Tags: ,

NAT试验笔记

分类:思科技术日期:2011-07-02 - 11:44:57评论:7条作者:老谢

NAT试验笔记

首先说一点吧,犯了一个很白痴的错误,刚搭好拓扑,R1无法与内网通信,老谢居然在R1上做了条默认路由

NAT的作用就是把内网IP转换成外网IP,我这样一来试验没有一点效果,而且在真实环境中,ISP不可能收到私网地址

PC0 IP:192.168.1.2

PC1 IP:192.168.1.3

静态NAT

R2(config)#ip nat inside source static 192.168.1.2 200.200.200.1
R2(config)#int fa0/0
R2(config-if)#ip nat inside 
R2(config-if)#ip nat outside 
R2(config-if)#end

动态NAT

注意:静态NAT配置clear不掉,必须no掉配置

步骤:定义ACL允许访问外网的地址、定义合法地址池、实现转换

R2(config)#access-list 1 permit 192.168.1.0 255.255.255.0
/*定义ACL*/
R2(config)#ip nat pool laoxie 200.200.200.1 200.200.200.1 netmask 255.255.255.0 
/*pool名称laoxie后面为范围*/
R2(config)#ip nat inside source list 1 pool laoxie
/*定义NAT使用list1的ACL和laoxie的pool*/
R2(config)#end

PAT

R2(config)#access-list 1 permit 192.168.1.0 0.0.0.255
R2(config)#ip nat pool laoxie 200.200.200.1 200.200.200.1 netmask 255.255.255.0
R2(config)#ip nat inside source list 1 pool laoxie overload
Tags: ,